Email Attachment Troubles

I’m facing a recurring issue with sending email attachments from my company’s email server. Whenever I try to attach a file, regardless of its size or format, the email fails to send, and I receive an error message stating, « Attachment Failed to Upload. » This problem is causing delays in important communications with clients and colleagues, and I’m concerned about the impact it’s having on our professional image.


  1. Attachments of all sizes and formats seem to be affected.
  2. I’ve tried sending emails with attachments through different email clients (Outlook, Gmail, etc.), but the problem persists.
  3. Other users within my company are not experiencing the same issue, suggesting it might be specific to my account or device.
  4. I’ve checked my internet connection and ensured that it’s stable and working fine.
  5. Restarting my device and email client hasn’t resolved the issue.
  6. There haven’t been any recent updates or changes to our email server or settings that could explain this problem. :smiling_face_with_tear: :slightly_smiling_face:

Any insights or suggestions on how to troubleshoot and resolve this issue would be greatly appreciated. Thank you!

Hi @joeroot , thanks for posting on this community!

I’m afraid I don’t have any specific answers here. Have you tried to contact our support team at the following address, to know more: