The API just returns 401 errors

I’ve created an account a few days ago and need to use the API. Without API access, Brevo is a no-go for us.

I’ve created a few API keys and every request I’ve ever made to the API has failed, returning a 401 error.

An example:

curl --location 'https://api.sendinblue.com/v3
/emailCampaigns?type=&status=&startDate=&endDate=&limit=50&offset=0&sort=desc' \
--header 'Accept: application/json' \
--header 'api-key: xkeysib-828c6........wMXKGUj'

Anyone else experiencing this? Is it because it’s a new account? I see other people are having the same problem as well

And how can we fix it?

Hi @xoel , by any chance: did you try to reach out to brevo support to know more? What did they reply?

I opened a ticket days ago and they haven’t replied yet

Now it worked, I didn’t change anything on my side besides setting the TXT DNS records in the morning (but it was still not working after that so I don’t think it was related)

ok thanks for the update @xoel ! that’s weird, indeed

Hi @xoel, sorry for the delay.

This is a recent development in our security that applies to every new account regarding authorized IPs. If our system is unable to identify whether the system using the API is good or bad, it sends an email to the user’s account and asks them to check whether they are the originator of the API call.

Did you receive this email?

At the creation of the API key, did you receive this message ?

My pleasure if you need any further information :slight_smile:

1 Like

Ah sorry yes, I forgot to mention that I found that and disabled the IP security checks on Brevo

We probably received an email like that but it’d arrive to my cofounder’s email.

Note that all of the products that have integrations with Brevo will be failing now because of this if you don’t whitelist their IPs on the background: Make was failing for me, and Zapier, etc will probably be failing for others too

1 Like